查看: 150|回复: 6

lu-asr01串口输出问题

[复制链接]

1

主题

6

帖子

33

积分

注册会员

Rank: 2

积分
33
发表于 2022-5-18 11:31:55 | 显示全部楼层 |阅读模式
lu-asr01选用TW-ASR ONE芯片,板载ch340g,通过串口输出数据,如果通过板载340转usb口,数据输出正确,通过io20口(tx)输出不正确,将串口1改到io5,io6,串口无输出。哪位有解决办法,回复一下,感谢!!!
回复

使用道具 举报

4

主题

33

帖子

298

积分

中级会员

Rank: 3Rank: 3

积分
298
发表于 2022-5-19 00:08:20 | 显示全部楼层
很显然,接在P20上的串口接收相关器件与线路有毛病
因为P20信号同时也是接到了板载340的RX上,公共的。只不过做了3.3V转5V的电平对接处理。
因此板载340能接收到消息,说明P20发送完全没有问题。
回复

使用道具 举报

1

主题

6

帖子

33

积分

注册会员

Rank: 2

积分
33
 楼主| 发表于 2022-5-19 08:35:05 | 显示全部楼层
我现在将串口1改到了p06,p07,输出不正确,输出应该为00,实际输出3F,输出应该为01,实际输出7F
回复

使用道具 举报

1

主题

6

帖子

33

积分

注册会员

Rank: 2

积分
33
 楼主| 发表于 2022-5-19 08:36:13 | 显示全部楼层
libai500 发表于 2022-5-19 00:08
很显然,接在P20上的串口接收相关器件与线路有毛病
因为P20信号同时也是接到了板载340的RX上,公共的。只不 ...

我另外用了一个340转接线,确认线没问题,从板载tx口接到转接线上,输出也不正确
回复

使用道具 举报

1

主题

6

帖子

33

积分

注册会员

Rank: 2

积分
33
 楼主| 发表于 2022-5-19 08:39:34 | 显示全部楼层
本帖最后由 wflzw 于 2022-5-19 08:42 编辑
libai500 发表于 2022-5-19 00:08
很显然,接在P20上的串口接收相关器件与线路有毛病
因为P20信号同时也是接到了板载340的RX上,公共的。只不 ...

现在是有输出,但是输出的数据是错误的。应该输出6B 61 69 64 65 6E 67 ,实际输出4A 4F 4B 53 D3 8A 2A
回复

使用道具 举报

1

主题

6

帖子

33

积分

注册会员

Rank: 2

积分
33
 楼主| 发表于 2022-5-19 09:19:01 | 显示全部楼层
libai500 发表于 2022-5-19 00:08
很显然,接在P20上的串口接收相关器件与线路有毛病
因为P20信号同时也是接到了板载340的RX上,公共的。只不 ...

这个图片同样p20口输出,输出com8口是板子340,com10口接板载tx口,com10口输出与串口1(p06,p07)输出数据是一致的,都不正确
1.png
回复

使用道具 举报

4

主题

33

帖子

298

积分

中级会员

Rank: 3Rank: 3

积分
298
发表于 2022-5-29 04:15:55 | 显示全部楼层
因340收到的信息与板载tx口信息是来自MCU同一引脚。
因此,如果板载tx口消息不正确,而340口消息正确,说明板载tx口电路一定有问题
问题可能如下:
1,可能3.3V兼容问题,板载Tx口是3.3V标准
2,GND与TX极性接反
3,....各种异常可能性。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|Archiver|手机版|小黑屋|好好搭搭在线 ( © 好好搭搭在线 浙ICP备19030393号-1 )

GMT+8, 2022-7-7 16:03 , Processed in 0.300032 second(s), 25 queries .

Powered by Discuz!

© 2001-2022 Comsenz Inc.

快速回复 返回顶部 返回列表